# Contents

## Using Enlighten™ in UE4 - Beginner tutorial

### Preface
- About this book ................................................................. 7
- Feedback .................................................................................. 9

### Chapter 1 Introduction
1.1 Introduction ........................................................................... 1-11
1.2 Opening the tutorial project ................................................... 1-12

### Chapter 2 Preparing the scene for Enlighten
2.1 Disabling Enlighten for BP_Sky_Sphere ................................... 2-14
2.2 An overview of Enlighten lighting modes in UE4 ..................... 2-16
2.3 Preparing actors to be lit by Enlighten lightmaps ...................... 2-17

### Chapter 3 Assigning Enlighten to actors
3.1 Assigning Enlighten lighting to detail actors ............................. 3-25
3.2 Assigning probe lighting to static actors .................................. 3-28
3.3 Assigning probe lighting to movable actors ............................. 3-30

### Chapter 4 Running the precompute and lighting the level
4.1 Running the precompute ...................................................... 4-33
4.2 Lighting the level ............................................................... 4-37

### Chapter 5 Summary
5.1 Summary ............................................................................... 5-42
Appendix A

Revisions

A.1 Revisions ................................................... ................................................... Appx-A-44
Using Enlighten™ in UE4 - Beginner tutorial

Copyright © 2016 ARM Limited or its affiliates. All rights reserved.

Release Information

<table>
<thead>
<tr>
<th>Issue</th>
<th>Date</th>
<th>Confidentiality</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>0000-00</td>
<td>14 December 2016</td>
<td>Non-Confidential</td>
<td>First release</td>
</tr>
</tbody>
</table>

Non-Confidential Proprietary Notice

This document is protected by copyright and other related rights and the practice or implementation of the information contained in this document may be protected by one or more patents or pending patent applications. No part of this document may be reproduced in any form by any means without the express prior written permission of ARM. No license, express or implied, by estoppel or otherwise to any intellectual property rights is granted by this document unless specifically stated.

Your access to the information in this document is conditional upon your acceptance that you will not use or permit others to use the information for the purposes of determining whether implementations infringe any third party patents.

THIS DOCUMENT IS PROVIDED “AS IS”. ARM PROVIDES NO REPRESENTATIONS AND NO WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY, SATISFACTORY QUALITY, NON-INFRINGEMENT OR FITNESS FOR A PARTICULAR PURPOSE WITH RESPECT TO THE DOCUMENT. For the avoidance of doubt, ARM makes no representation with respect to, and has undertaken no analysis to identify or understand the scope and content of, third party patents, copyrights, trade secrets, or other rights.

This document may include technical inaccuracies or typographical errors.

TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL ARM BE LIABLE FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF ANY USE OF THIS DOCUMENT, EVEN IF ARM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

This document consists solely of commercial items. You shall be responsible for ensuring that any use, duplication or disclosure of this document complies fully with any relevant export laws and regulations to assure that this document or any portion thereof is not exported, directly or indirectly, in violation of such export laws. Use of the word “partner” in reference to ARM’s customers is not intended to create or refer to any partnership relationship with any other company. ARM may make changes to this document at any time and without notice.

If any of the provisions contained in these terms conflict with any of the provisions of any signed written agreement covering this document with ARM, then the signed written agreement prevails over and supersedes the conflicting provisions of these terms. This document may be translated into other languages for convenience, and you agree that if there is any conflict between the English version of this document and any translation, the terms of the English version of the Agreement shall prevail.

Words and logos marked with ® or ™ are registered trademarks or trademarks of ARM Limited or its affiliates in the EU and/or elsewhere. All rights reserved. Other brands and names mentioned in this document may be the trademarks of their respective owners. Please follow ARM’s trademark usage guidelines at http://www.arm.com/about/trademark-usage-guidelines.php

Copyright © 2016, ARM Limited or its affiliates. All rights reserved.


110 Fulbourn Road, Cambridge, England CB1 9NJ.

LES-PRE-20349

Confidentiality Status

This document is Non-Confidential. The right to use, copy and disclose this document may be subject to license restrictions in accordance with the terms of the agreement entered into by ARM and the party that ARM delivered this document to.

Unrestricted Access is an ARM internal classification.
Product Status
The information in this document is Final, that is for a developed product.

Web Address
http://www.arm.com
Preface

This preface introduces the *Using Enlighten™ in UE4 - Beginner tutorial*. It contains the following:

About this book
A beginner-level tutorial for applying Enlighten indirect lighting in UE4.

Product revision status
The rm\text{\textsuperscript{pn}} identifier indicates the revision status of the product described in this book, for example, r1\text{\textsuperscript{p2}}, where:
\begin{itemize}
  \item \textit{rm} Identifies the major revision of the product, for example, r1.
  \item \textit{pn} Identifies the minor revision or modification status of the product, for example, p2.
\end{itemize}

Intended audience
This resource is for users of UE4 who are beginning to use Enlighten.

Using this book
This book is organized into the following chapters:

\textit{Chapter 1 Introduction}
An introduction to the tutorial including aims, prerequisites, and an overview of the Enlighten workflow.

\textit{Chapter 2 Preparing the scene for Enlighten}
How to disable Enlighten for large sky dome actors, an overview of Enlighten lighting modes, and how to prepare actors to be lit by Enlighten.

\textit{Chapter 3 Assigning Enlighten to actors}
How to assign Enlighten lighting to detail actors, static actors, and movable actors.

\textit{Chapter 4 Running the precompute and lighting the level}
How to run the Enlighten precompute and add direct lighting to the tutorial level that interacts with Enlighten indirect lighting.

\textit{Chapter 5 Summary}
A summary of the tasks completed in the tutorial and some guidance for next steps and troubleshooting.

\textit{Appendix A Revisions}
This appendix describes the technical changes between released issues of this tutorial.

Glossary
The ARM Glossary is a list of terms used in ARM documentation, together with definitions for those terms. The ARM Glossary does not contain terms that are industry standard unless the ARM meaning differs from the generally accepted meaning.

See the \textit{ARM Glossary} for more information.

Typographic conventions
\begin{itemize}
  \item \textit{italic} Introduces special terminology, denotes cross-references, and citations.
  \item \textbf{bold} Highlights interface elements, such as menu names. Denotes signal names. Also used for terms in descriptive lists, where appropriate.
  \item \texttt{monospace} Denotes text that you can enter at the keyboard, such as commands, file and program names, and source code.
\end{itemize}
monospace
Denotes a permitted abbreviation for a command or option. You can enter the underlined text instead of the full command or option name.

monospace italic
Denotes arguments to monospace text where the argument is to be replaced by a specific value.

monospace bold
Denotes language keywords when used outside example code.

<and>
Encloses replaceable terms for assembler syntax where they appear in code or code fragments. For example:

    MRC p15, 0, <Rd>, <CRn>, <CRm>, <Opcode_2>

SMALL CAPITALS
Used in body text for a few terms that have specific technical meanings, that are defined in the ARM glossary. For example, IMPLEMENTATION DEFINED, IMPLEMENTATION SPECIFIC, UNKNOWN, and UNPREDICTABLE.

Additional reading

ARM publications
Other publications
Feedback

Feedback on this product

If you have any comments or suggestions about this product, contact your supplier and give:
• The product name.
• The product revision or version.
• An explanation with as much information as you can provide. Include symptoms and diagnostic procedures if appropriate.

Feedback on content

If you have comments on content then send an e-mail to errata@arm.com. Give:
• The title Using Enlighten™ in UE4 - Beginner tutorial.
• The number ARM 100844_0000_00_en.
• If applicable, the page number(s) to which your comments refer.
• A concise explanation of your comments.

ARM also welcomes general suggestions for additions and improvements.

_________ Note __________

ARM tests the PDF only in Adobe Acrobat and Acrobat Reader, and cannot guarantee the quality of the represented document when used with any other PDF reader.
Chapter 1
Introduction

An introduction to the tutorial including aims, prerequisites, and an overview of the Enlighten workflow.

It contains the following sections:
• 1.1 Introduction on page 1-11.
• 1.2 Opening the tutorial project on page 1-12.
1.1 Introduction

This is a beginner-level tutorial for people with little or no experience of using Enlighten in *Unreal Engine 4* (UE4).

The tutorial is designed to help you understand the basic concepts of Enlighten and evaluate Enlighten in UE4. It is assumed that you know how to work with UE4 projects, and understand basic use of the standard UE4 editor.

Additional information is provided at the end of relevant sections throughout this tutorial, in sections labeled **Advanced information**. This information is optional and is not required to follow the steps in the tutorial.

**Aim**

The aim of this tutorial is for you to configure and apply Enlighten indirect lighting in a small scene. This is achieved through easy to follow steps and explanations that introduce the Enlighten workflow and some of the main Enlighten lighting concepts.

When you have completed this tutorial, you can apply the steps and the information to use Enlighten in your own scenes.

**Outcomes**

By the end of this tutorial, you will be able to:

- Configure Enlighten in a small scene. This is done by assigning appropriate Enlighten lighting modes to assets, optimizing Enlighten properties, and running the Enlighten precompute.
- Author direct lighting that causes Enlighten indirect lighting to update in real-time. After the Enlighten precompute, lights placed in the scene will interact with Enlighten to update the indirect lighting.

**Requirements**

To successfully complete this tutorial, you need:

- Enlighten for UE4 version 3.06 (QA Build 4.12) or later.
- The `EnlightenUE4-<release-version>_EnlightenTutorials.zip` UE4 project folder. This is available from the Enlighten downloads site.

This guide does not cover integrating and building Enlighten for UE4. You need a working UE4 Editor that is built with Enlighten UE4 before starting this tutorial.

**The Enlighten workflow**

This tutorial introduces a generic Enlighten workflow that is also applicable to your own UE4 scenes. The main steps of the workflow and how they are applied in this tutorial are illustrated in this diagram.

![Enlighten UE4 workflow diagram](image-url)
### 1.2 Opening the tutorial project

The Enlighten tutorial project folder contains the project file and all the necessary assets and files that are required for this tutorial.

To load the project:
1. In UE4, open the Enlighten tutorial project that you have downloaded and load the `Tutorial_Begin` level.
2. If the Convert Project dialog window appears, select More Options... > Skip Conversion. Ignore any map check warnings, which can be caused by minor version differences.

To see Enlighten lighting updates in the main viewport, the Realtime option must be enabled. Enable Realtime in the Viewport Options menu, as shown in this screenshot.

![Viewport Options menu](image_url)
Chapter 2
Preparing the scene for Enlighten

How to disable Enlighten for large sky dome actors, an overview of Enlighten lighting modes, and how to prepare actors to be lit by Enlighten.

It contains the following sections:
• 2.1 Disabling Enlighten for BP_Sky_Sphere on page 2-14.
• 2.2 An overview of Enlighten lighting modes in UE4 on page 2-16.
• 2.3 Preparing actors to be lit by Enlighten lightmaps on page 2-17.
2.1 Disabling Enlighten for BP_Sky_Sphere

Enlighten must be disabled for the BP_Sky_Sphere actor because it is too large to be lit by Enlighten.

Many projects that are created in UE4 include the default BP_Sky_Sphere actor. Disabling Enlighten for the BP_Sky_Sphere actor is necessary to allow the Enlighten precompute to complete successfully.

In general, the following steps also apply to similar sky dome geometry in your own projects.

To disable Enlighten for the BP_Sky_Sphere in the Tutorial_Begin level:
1. Select the BP_Sky_Sphere object in the World Outliner tab.
2. From the Details tab, select the Sky Sphere Mesh (inherited) object that is located beneath the Base component.
3. From the Enlighten submenu, set Override Enlighten Lighting Mode and set Enlighten Lighting Mode Override to Disabled, as shown in this image.
Enlighten is now disabled for the BP_Sky_Sphere actor.

**Advanced information**

Setting the Enlighten lighting mode to **Disabled** stops the actor from being included in the Enlighten precompute. As a result, the actor is not included in any Enlighten indirect lighting calculations. This saves precompute time and runtime memory.

For actors as large as sky domes, the precompute fails if the lighting mode is set to the default of **Contribute Lightmap**. This is because it would require too many lightmap pixels.
2.2 An overview of Enlighten lighting modes in UE4

To generate indirect lighting, Enlighten uses two main lighting modes. These are Enlighten lightmaps and Enlighten light probes.

Enlighten lightmap and probe lighting is applied to actors in one of the following ways:

**Enlighten lightmaps**

Lightmaps are useful for lighting meshes that have a large continuous surface area, such as the floor and walls of a room. Lightmap lighting can only be used on actors that do not move. Actors are assigned lightmap lighting using these modes:

- **Contribute Lightmap.** This mode is the default for actors with Mobility set to Static. Actors set to Contribute Lightmap receive, bounce, and occlude indirect light.
- **Detail.** This option is used on small detailed meshes which can reuse the same indirect lighting as nearby larger meshes. Detail mesh actors do not occlude or bounce light. This lighting mode helps improve performance by indicating to Enlighten that the mesh has low impact on the indirect lighting.

**Enlighten light probes**

Actors using probe lighting modes receive indirect lighting from nearby Enlighten light probes. Probe lighting works best with complex meshes that have many small features such as foliage, characters, or small objects. Probe lighting can be used for actors that move, and for actors that do not move. Actors are assigned probe lighting using these modes:

- **Probe.** This is the default lighting mode for actors with Mobility set to Movable. Actors set to Probe receive indirect illumination but do not occlude or bounce indirect light.
- **Contribute probe.** This option allows static probe-lit meshes to block and bounce indirect lighting in the scene. This is used for complex meshes as an alternative to Contribute Lightmap. In general, trees and other complex foliage objects that contribute to indirect lighting are suitable for this mode.
2.3 Preparing actors to be lit by Enlighten lightmaps

Enlighten lightmap lighting can be optimized to reduce Enlighten update and precompute times. Prepare actors by assigning appropriate quality levels and viewing Enlighten charts to visualize the results.

By default, all actors in UE4 are assigned to be lightmap lit. This means that for all actors in a scene, the Enlighten Lighting Mode in the Details tab is initially set to Contribute Lightmap, as highlighted in this image.

![Figure 2-3 Lighting mode menu option](image)

When the number of Enlighten lightmap pixels that are used by the actors in the level increases, the time that is taken to update the Enlighten lighting in the game and to run the Enlighten precompute for the level also increases.

To help reduce these times, you can optimize Enlighten quality levels to ensure that lightmap resolution is appropriate for the location of actors in game play.

Enlighten categorizes lightmap resolution as levels of quality.

You must assign the appropriate lightmap quality level to actors that are lit by lightmaps.

Enlighten has four light map quality levels:

1. High. For assigning to actors that are likely to be in close proximity to game play.
2. Medium. For assigning to actors that are likely to be in medium proximity to game play.
3. Low. For assigning to actors that are not likely to be in the proximity of game play.
4. Background. For assigning to background actors far outside the proximity of game play.

The default lightmap quality level for actors using the Contribute Lightmap lighting mode is high. Therefore, only change the quality level for actors that are not likely to be in close proximity to game play and where detail in the indirect lighting is not as important.

For actors with the quality mode set to High, Enlighten generates lightmaps with pixels approximately 1 square meter in size.

________ Important _______

For efficient performance, a recommended initial value for the output pixel size is one pixel per meter. This equates to 100 units when 1cm = 1 unit.

Although this value is large when compared to traditional light map bakers, it is generally sufficient for Enlighten lightmaps.

To change this value, select World Settings > Enlighten Settings > Quality Levels > Level > System Parameters > Output Pixel Size, as this image shows.
This section contains the following subsections:

- 2.3.1 Previewing charts on page 2-18.
- 2.3.2 Assigning lightmap quality levels to actors on page 2-21.

### 2.3.1 Previewing charts

Enlighten charts are previewed by running a parameterize build. This helps you to visualize Enlighten charts and apply appropriate lightmap quality settings.

Changes to the lightmap quality settings are only visible in the scene after a precompute is run. However, you can also preview the impact of the current settings by running a parameterize build. A parameterize build takes less time to run than a precompute and allows you to quickly iterate over different quality settings.

To parameterize the scene and preview the Enlighten charts:

1. Expand the drop-down menu from the Build options, and select Build Enlighten > Parameterize > Current level. This option is shown in the following screenshot. Enlighten takes a few minutes to parameterize the scene.
2. From the Show menu, select **Enlighten** > **Enlighten Charts**.

**Figure 2-5** Parameterize current level menu option

**Figure 2-6** Enlighten charts menu option
The following image shows the scene with the Enlighten charts view enabled in **Unlit** mode.

![Enlighten charts view in unlit mode](image)

**Figure 2-7** Enlighten charts view in unlit mode

In this view, individual charts are shown in different colors and each square within each chart shows the size of the lightmap pixels. Each chart represents a unique area in the Enlighten lightmap.

**Troubleshooting: Failed parameterize**

If you have not disabled Enlighten for BP_Sky_Sphere, the parameterize build fails.

If the parameterize build fails, the following notification will be shown:

![Enlighten precompute had errors](image)

**Figure 2-8** Enlighten precompute error

To show the Enlighten errors log, click **Show Message Log**. An Enlighten errors log is shown in this screenshot.
2.3.2 Assigning lightmap quality levels to actors

By default, all actors using the Contribute Lightmap lighting mode are assigned the high quality level. For street scenes such as the tutorial level, the high quality level provides acceptable lighting resolution for actors that are in close proximity to game play.

There are some areas of the tutorial level that are not in close proximity to game play. To ensure that the cost of Enlighten lighting is not too high, you must select the appropriate lightmap resolution for the actors in these areas.

Tip

You can safely reduce the lightmap resolution for actors that are always seen from far away by changing the quality level. A reduced lightmap resolution has no negative impact on the visual quality unless the actor can be seen up close.

To view the contents of the scene and assign the appropriate quality levels for the actors:

1. Select Window > World Outliner to open the World Outliner tab.
2. In the World Outliner tab, navigate to the Assets\Buildings folder. In this folder, actors are grouped into subfolders that are based on the location of the actors in the scene and whether they are player facing. Actors that are likely to be in close proximity to game play, where lighting detail matters, are located in the PlayerFacing folders. Actors that are not likely to be in proximity to game play are located in Non_PlayerFacing folders.
3. Only the quality levels of the actors in the Non_PlayerFacing folders require changing. To do this:
   a. Navigate to StreetBlock_East\Non_PlayerFacing.
   b. Select all the actors in this folder by right-clicking on the folder and selecting Select> All descendants, as this image shows.
c. With all the actors selected, navigate to the Enlighten submenu in the Details tab. Select Window > Details, then scroll down to the Enlighten submenu.

d. Change the value of Enlighten Quality to Low. This changes the quality level for all the actors that you have selected.

4. Repeat step 3 for all actors in the other Non_PlayerFacing folders to change their Enlighten Quality level to Low.

5. Change the quality level for background actors. Repeat step 3 for the actors in the Buildings \Background folder but change the Enlighten Quality level to Background.
6. Run the Parameterization build again. To do this, select the Build drop-down, then select Re-run Enlighten Parameterize.

The following shows the Enlighten Charts view mode after Parameterize has been run with the new quality levels.

---

**Note**

In the EnlightenTutorials project, actors are grouped in folders depending on their location and their game play proximity. This is done to organize actors in the tutorial level and is not a requirement of Enlighten.
Chapter 3
Assigning Enlighten to actors

How to assign Enlighten lighting to detail actors, static actors, and movable actors.

It contains the following sections:

- 3.1 Assigning Enlighten lighting to detail actors on page 3-25.
- 3.2 Assigning probe lighting to static actors on page 3-28.
- 3.3 Assigning probe lighting to movable actors on page 3-30.
3.1 Assigning Enlighten lighting to detail actors

Enlighten does not create lightmap charts for detail actors. Instead, the charts from larger actors are overlaid onto detail actors.

Every actor that uses the **Contribute Lightmap** lighting mode generates a unique chart in the lightmap. Decals and small detail actors do not need to have their own space in the lightmap and are suitable candidates to use the **Detail** lighting mode.

Actors that use the **Detail** lighting mode do not generate their own charts but instead use the same chart from a nearby actor. By using the same chart and pixels from a nearby actor, Enlighten can make optimal use of the lightmap space. This results in fewer overall pixels and improved performance with no noticeable loss in visual quality.

In the tutorial scene, there are posters on building walls. These types of objects are suitable for using the **Detail** lighting mode because they are small actors that are overlaid onto larger actors. Currently, these posters are set to use the **Contribute Lightmap** lighting mode.

To locate the posters, view their charts, and assign **Detail** lighting mode to the posters:

1. In the viewport, navigate to the small alleyway between the buildings on the main street. On the left-hand wall are three posters, as shown in this image.

![Figure 3-1 Viewport showing posters on a wall](image)

2. To see their charts, from the **Show** menu, select **Enlighten > Enlighten Charts**, as shown in this image.
3. The following image shows three charts that represent the three posters. These poster charts are overlaying the chart for the building wall.
4. Select all three posters in the viewport. To do this, hold down the Ctrl key and left-click on the posters in the viewport.

5. In the details tab, select Detail from the Enlighten Lighting Mode Override menu to change the lighting mode for all three posters to Detail.

The lighting mode for the posters is now set to Detail.

As the following image shows, the charts for the posters have been removed. This has reduced the overall number of charts, making Enlighten more efficient. The posters will be lit using Enlighten lightmap pixels from the building wall.
3.2 Assigning probe lighting to static actors

Enlighten automatically generates probes around Static actors that are lit using the Probe lighting mode.

Actors using the Probe lighting mode do not block or reflect indirect light. This makes the Probe lighting mode suitable for small props which would not have a significant effect on the indirect lighting in the scene.

The tutorial scene contains lamp posts that are set to Contribute Lightmap mode. To assign the lamp post actors to be probe-lit:

1. In the World Outliner tab, navigate to Assets\Props.
2. Double-click on one of the lamp post assets in the folder, for example Props_LampPost01. The lamp post is shown in the viewport.
3. With the actor selected, in the Details tab change the Enlighten lighting mode to Probe from the Set Lighting Mode On Base Mesh drop-down menu in the Enlighten menu as the image shows.

Figure 3-5 Viewport showing lamp post asset
Changing the lighting mode on the base mesh changes the lighting mode for all actors that share the same base mesh. This means that any other lamp posts in the scene, that are derived from the same base meshes as the ones you have modified, will also have their lighting mode changed. In contrast, changing the lighting mode for actors per-instance does not affect any other actor in the scene.

### Advanced information

#### Choosing Probe or Contribute Probe lighting modes

There are two probe lighting modes for static actors. Select a mode based on how much impact the actor is expected to have on the indirect lighting.

1. **Probe.** In this mode, actors are lit by probes but do not themselves affect the indirect lighting in the scene. Actors using this mode are not included in the Enlighten precompute, which saves precompute time, and reduces the cost of updating Enlighten at runtime.

2. **Contribute Probe.** In this mode, actors are lit from nearby probes and participate in the indirect lighting. This is means that light is bounced from the actor and the actor blocks indirect lighting.
3.3 Assigning probe lighting to movable actors

Actors that are set to Movable are lit using light probes.

Enlighten does not automatically generate probes around Movable actors, such as the player character, because they may move during gameplay. For Enlighten to light Movable actors, you must place an Enlighten Adaptive Probe Volume into a scene to cover all the areas where Movable actors can move.

The tutorial scene contains rubbish boxes that are suitable for moving during gameplay. They must be set to Movable and an Enlighten Adaptive Probe Volume must be placed into the scene.

To set the rubbish boxes to Movable:

1. Select all the actors in the MovableBoxes folder by right-clicking and choosing Select > All Descendants.

2. With the actors selected, in the Details tab change the Mobility setting to Movable.
To create an adaptive probe volume, place it into the scene, and set the scale and size:

1. In **Mode** > **Search Classes**, type *enlighten*. Drag the **Enlighten Adaptive Probe Volume** object into the viewport.

![Figure 3-9 The Enlighten Adaptive Probe Volume object](image)

2. Select the object in the viewport and increase the size of the volume to contain the contents of the scene. To increase the size of the volume, select the **Select and scale** tool in the viewport or modify the scale values in the details tab. Both of these options are shown in the following image.

![Figure 3-10 Enlighten adaptive probe volume and the select and scale tool in the viewport](image)
Chapter 4
Running the precompute and lighting the level

How to run the Enlighten precompute and add direct lighting to the tutorial level that interacts with Enlighten indirect lighting.

It contains the following sections:
• 4.1 Running the precompute on page 4-33.
• 4.2 Lighting the level on page 4-37.
4.1 Running the precompute

Running the Enlighten precompute generates Enlighten data for the tutorial level. This data is used to update lighting in real-time.

To run the precompute:
1. From the Build drop-down menu, select Build Enlighten > Precompute > Current level, as shown in this image.

![Figure 4-1 Precompute current level menu option](image)

2. The precompute takes a few minutes to complete. During the precompute, GeoPrecompMonitor displays the progress of the precompute as this image shows.

![Figure 4-2 The GeoPreCompMonitor interface](image)

After a successful precompute, Enlighten is ready to update the indirect lighting. To view the effects of indirect lighting, some direct lights must be added to the scene.

**Troubleshooting: Failed precompute**

If the precompute fails, the most likely cause is that the Enlighten license file is missing or invalid. To ensure that you have correctly licensed Enlighten, place an up-to-date Enlighten license file in the UE4 root folder.
**Advanced information: Enlighten view modes**

The Enlighten view modes allow you to view how Enlighten has been configured throughout the scene.

To enable an Enlighten view mode, select an Enlighten show flag from the **Show > Enlighten** menu, which is accessed in the viewport. The following image shows the Enlighten show flags in the **Show** menu.

![Figure 4-3  Enlighten show flags in the Show menu](image)

Useful modes include:

1. **Enlighten light mode**. This highlights all actors in the scene corresponding to their assigned lighting mode. In the following image, orange indicates light-map lit, blue indicates detail geometry, and yellow indicates contribute-probe lit.
2. **Enlighten quality level.** This shows the different light map quality levels. This is useful to check for consistency across actors in a scene, and for easily identifying quality levels.

3. **Enlighten probe positions.** This shows where Enlighten has placed probes. This is useful to determine the correct size and position of your adaptive probe volume so that all Movable objects have sufficient probe density in areas where it is important.
4 Running the precompute and lighting the level
4.1 Running the precompute

Figure 4-6 Enlighten probe positions view
4.2 Lighting the level

After the precompute, direct lights that are placed in the scene interact with Enlighten indirect lighting in real-time.

In the tutorial level, set the view mode to Lit, configure a directional light, and place an Enlighten texture environment in the scene.

To light the level with both direct and Enlighten indirect lighting:
1. To show the lighting in the scene, select Lit from the View mode menu.

   ![Figure 4-7 The Lit option in the View Mode menu](image)

   As this image shows, the scene appears dark because there are no direct lights to interact with Enlighten.

   ![Figure 4-8 Tutorial level in Lit view with no direct lights](image)

2. To add a direct light to the level, drag the Directional Light object into the viewport. The directional light object is located in Lights options in the Mode tab, as this image shows.
3. Select the newly created directional light actor and set Details > Transform > Mobility to Movable. By default, the setting is Stationary, which means that it would be necessary to bake shadows using Lightmass.

4. Change the Rotation and Light Color. As this image shows, the indirect light in the level updates.
5. Enlighten handles sky lighting with the Enlighten Texture Environment object. In the search bar in the Modes window, type enlighten. Drag the Enlighten Texture Environment object into the viewport to create a new actor.

6. Change the Brightness and Environment Color properties to control the color of the light from the sky.
Enlighten is now configured in the tutorial level. The level is ready for direct lighting to be added and configured. The direct lighting will interact with Enlighten indirect lighting.
Chapter 5
Summary

A summary of the tasks completed in the tutorial and some guidance for next steps and troubleshooting.

It contains the following sections:
• 5.1 Summary on page 5-42.
5.1 Summary

After applying the instructions in the tutorial, Enlighten is now configured in the tutorial scene.

By following the steps in this tutorial, you have performed a basic integration of Enlighten in UE4. This includes:

• Disabling Enlighten lighting modes for large sky dome geometries, such as the BP_Sky_Sphere actor.
• Selecting appropriate Enlighten lightmap quality levels.
• Previewing Enlighten charts in the viewport to help you visualize and assign appropriate lightmap quality levels and Enlighten lighting modes.
• Assigning small detail actors to use the lightmaps of overlapping larger actors by using the Enlighten Detail lighting mode.
• Assigning probe lighting to static actors by using the Enlighten Probe lighting mode.
• Setting actors to be Movable and use the Enlighten Adaptive Probe Volume so that they receive Enlighten probe lighting.
• Running the Enlighten precompute to create Enlighten data that produces real-time indirect lighting updates.
• Adding and configured direct light that interacts with Enlighten indirect lighting in real-time.
• Applying an Enlighten Texture Environment object to modify the color and brightness of sky lighting.

Next steps

Apply the steps in this tutorial to configure and use Enlighten in your own UE4 projects.

For more information on using Enlighten in UE4, see Enlighten UE4 Integration 3.07 Documentation.

Troubleshooting and support

If you have any questions or issues that relate to this tutorial, email Geomerics support, mailto:support@geomeric.com.
Appendix A
Revisions

This appendix describes the technical changes between released issues of this tutorial.

It contains the following sections:
• A.1 Revisions on page Appx-A-44.
### A.1 Revisions

Each table lists the technical differences between successive issues of this tutorial.

<table>
<thead>
<tr>
<th>Change</th>
<th>Location</th>
<th>Affects</th>
</tr>
</thead>
<tbody>
<tr>
<td>First release</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>