DesignStart FPGA on Cloud

Arm DS Getting Started Guide

Copyright © 2019 Arm Limited (or its affiliates). All rights reserved.

Release information

Document history

<table>
<thead>
<tr>
<th></th>
<th>Date</th>
<th>Confidentiality</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>15 November 2019</td>
<td>Non-Confidential</td>
<td>First release for r0p0</td>
</tr>
<tr>
<td>B</td>
<td>25 November 2019</td>
<td>Non-Confidential</td>
<td>Additional information related to multi core debug</td>
</tr>
<tr>
<td>C</td>
<td>07 February 2020</td>
<td>Non-Confidential</td>
<td>Update TF-M example</td>
</tr>
</tbody>
</table>

Non-Confidential Proprietary Notice

This document is protected by copyright and other related rights and the practice or implementation of the information contained in this document may be protected by one or more patents or pending patent applications. No part of this document may be reproduced in any form by any means without the express prior written permission of Arm. **No license, express or implied, by estoppel or otherwise to any intellectual property rights is granted by this document unless specifically stated.**

Your access to the information in this document is conditional upon your acceptance that you will not use or permit others to use the information: (i) for the purposes of determining whether implementations infringe any third party patents; (ii) for developing technology or products which avoid any of Arm’s intellectual property; or (iii) as a reference for modifying existing patents or patent applications or creating any continuation, continuation in part, or extension of existing patents or patent applications; or (iv) for generating data for publication or disclosure to third parties, which compares the performance or functionality of the Arm technology described in this document with any other products created by you or a third party, without obtaining Arm’s prior written consent.

THIS DOCUMENT IS PROVIDED “AS IS”. ARM PROVIDES NO REPRESENTATIONS AND NO WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY, SATISFACTORY QUALITY, NONINFRINGEMENT OR FITNESS FOR A PARTICULAR PURPOSE WITH RESPECT TO THE DOCUMENT. For the avoidance of doubt, Arm makes no representation with respect to, and has undertaken no analysis to identify or understand the scope and content of, third party patents, copyrights, trade secrets, or other rights.

This document may include technical inaccuracies or typographical errors.

TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL ARM BE LIABLE FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF ANY USE OF THIS DOCUMENT, EVEN IF ARM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Copyright © 2019 Arm Limited (or its affiliates). All rights reserved.
Non Confidential
This document consists solely of commercial items. You shall be responsible for ensuring that any use, duplication or disclosure of this document complies fully with any relevant export laws and regulations to assure that this document or any portion thereof is not exported, directly or indirectly, in violation of such export laws. Use of the word “partner” in reference to Arm’s customers is not intended to create or refer to any partnership relationship with any other company. Arm may make changes to this document at any time and without notice.

If any of the provisions contained in these terms conflict with any of the provisions of any click through or signed written agreement covering this document with Arm, then the click through or signed written agreement prevails over and supersedes the conflicting provisions of these terms. This document may be translated into other languages for convenience, and you agree that if there is any conflict between the English version of this document and any translation, the terms of the English version of the Agreement shall prevail.

The Arm corporate logo and words marked with ® or ™ are registered trademarks or trademarks of Arm Limited (or its subsidiaries) in the US and/or elsewhere. All rights reserved. Other brands and names mentioned in this document may be the trademarks of their respective owners. Please follow Arm’s trademark usage guidelines at http://www.arm.com/company/policies/trademarks.

Copyright © 2019 Arm Limited (or its affiliates). All rights reserved.


110 Fulbourn Road, Cambridge, England CB1 9NJ.

LES-PRE-20348

Confidentiality Status

This document is Non-Confidential. The right to use, copy and disclose this document may be subject to license restrictions in accordance with the terms of the agreement entered into by Arm and the party that Arm delivered this document to. Unrestricted Access is an Arm internal classification.

Product Status

The information in this document is Final, that is for a developed product.

Web Address

http://www.arm.com
Contents

1 Preface ................................................................................................................................................. 6
   1.1 Product revision status .................................................................................................................. 6
   1.2 Intended audience ......................................................................................................................... 6
   1.3 Conventions .................................................................................................................................. 6
   1.3.1 Glossary .................................................................................................................................... 6
   1.3.2 Typographical conventions ...................................................................................................... 7
   1.4 Additional reading ....................................................................................................................... 8
   1.5 Feedback ....................................................................................................................................... 8
      1.5.1 Feedback on this product ...................................................................................................... 8
      1.5.2 Feedback on content ............................................................................................................ 8

2 Introduction ............................................................................................................................................ 9

3 Setting up AWS and Arm DS .............................................................................................................. 10
   3.1 Prerequisites .................................................................................................................................. 10
   3.2 Host setup ...................................................................................................................................... 10
   3.3 Client setup .................................................................................................................................... 10
   3.4 Using Arm DS with DesignStart FPGA on cloud ......................................................................... 15
   3.5 Creating new Arm DS debug configuration .................................................................................. 16

4 Building, running, and debugging test applications .......................................................................... 20
   4.1 Hello World Example ................................................................................................................... 20
      4.1.1 Creating the Arm DS project ................................................................................................. 20
      4.1.2 Configure your debug session ............................................................................................... 22
   4.2 Arm Trusted Firmware M (TF-M) Example .................................................................................. 25
      4.2.1 Dependencies ....................................................................................................................... 25
      4.2.2 Building TF-M ....................................................................................................................... 25
      4.2.3 Loading and running the binaries on AWS ........................................................................... 30
      4.2.4 Debugging TF-M example ..................................................................................................... 30

5 Troubleshooting ..................................................................................................................................... 35
   5.1 How do I start debugging from main? ............................................................................................ 35
   5.2 Can't debugging both CPUs ......................................................................................................... 35
1 Preface

1.1 Product revision status

The \textit{rm}pn identifier indicates the revision status of the product described in this document, for example, r1p2, where:

\begin{itemize}
  \item \textit{rm} Identifies the major revision of the product, for example, r1.
  \item \textit{pn} Identifies the minor revision or modification status of the product, for example, p2.
\end{itemize}

1.2 Intended audience

This document is written to provide information to hardware and software engineers who are implementing designs on Amazon Web Services (AWS). This document is written for experienced hardware and software engineers who might or might not have experience of Arm products, but who have experience of writing software and of targeting development platforms.

1.3 Conventions

The following subsections describe conventions used in Arm documents.

1.3.1 Glossary

The Arm Glossary is a list of terms used in Arm documentation, together with definitions for those terms. The Arm Glossary does not contain terms that are industry standard unless the Arm meaning differs from the generally accepted meaning.

See the Arm Glossary for more information.
### 1.3.2 Typographical conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>bold</strong></td>
<td>Highlights interface elements, such as menu names. Denotes signal names. Also used for terms in descriptive lists, where appropriate.</td>
</tr>
<tr>
<td>monospace</td>
<td>Denotes text that you can enter at the keyboard, such as commands, file and program names, and source code.</td>
</tr>
<tr>
<td>Monospace <strong>bold</strong></td>
<td>Denotes language keywords when used outside example code.</td>
</tr>
<tr>
<td>monospace italic</td>
<td>Denotes arguments to monospace text where the argument is to be replaced by a specific value.</td>
</tr>
<tr>
<td>monospace underline</td>
<td>Denotes a permitted abbreviation for a command or option. You can enter the underlined text instead of the full command or option name.</td>
</tr>
<tr>
<td>&lt;and&gt;</td>
<td>Encloses replaceable terms for assembler syntax where they appear in code or code fragments. For example: <code>MRC p15, 0, &lt;Rd&gt;, &lt;CRn&gt;, &lt;CRm&gt;, &lt;Opcode_2&gt;</code></td>
</tr>
<tr>
<td>SMALL CAPITALS</td>
<td>Used in body text for a few terms that have specific technical meanings, that are defined in the Arm® Glossary. For example, IMPLEMENTATION DEFINED, IMPLEMENTATION SPECIFIC, UNKNOWN, and UNPREDICTABLE.</td>
</tr>
<tr>
<td>Caution</td>
<td></td>
</tr>
<tr>
<td>Warning</td>
<td></td>
</tr>
<tr>
<td>Note</td>
<td></td>
</tr>
</tbody>
</table>
1.4 Additional reading

This document contains information that is specific to this product. See the following documents for other relevant information:

Arm publications

- Arm Development Studio Getting Started Guide

Other publications

- Amazon EC2 F1 Instances

1.5 Feedback

Arm welcomes feedback on this product and its documentation.

1.5.1 Feedback on this product

If you have any comments or suggestions about this product, contact your supplier and give:

- The product name
- The product revision or version
- An explanation with as much information as you can provide. Include symptoms and diagnostic procedures if appropriate.

1.5.2 Feedback on content

If you have comments on content, send an e-mail to rce-contact@arm.com and give:

- The title Arm DS Getting Started Guide
- If applicable, the page numbers to which your comments refer
- A concise explanation of your comments

Arm also welcomes general suggestions for additions and improvements.

Arm tests the PDF only in Adobe Acrobat and Acrobat Reader, and cannot guarantee the quality of the represented document when used with any other PDF reader.
2 Introduction

Amazon Web Services (AWS) is a cloud provider that enables you to create virtual private server instances, some of which include a Field Programmable Gate Array (FPGA) that can be programmed to run your own software payloads. Arm Development Studio (Arm DS) allows you to connect to this AWS instance from your local machine and remotely debug the software payload.

This Getting Started Guide is intended to provide:

- Information on how to set up an AWS FPGA instance
- Information on how to connect a local Arm DS installation to the AWS instance
- Information on building test applications, running them on AWS, and debugging them from a local Arm DS installation
- Troubleshooting information for configuring AWS and Arm DS
3 Setting up AWS and Arm DS

This document describes the steps that are necessary to use Arm DS with the DesignStart FPGA on Cloud offering on AWS. The solution is based on a server-client architecture, where the AWS instance acts as the server, while a remote computer acts as the client.

3.1 Prerequisites

In order to ensure that you can connect to the instance, the following items are required:

- The AWS EC2 F1 instance is launched by selecting the "DesignStart FPGA on Cloud with ArmDS Software Debug Enabled 1.0" AMI.
- A valid Arm DS license and DS installation version 2019.1 or above on the user's host machine.

3.2 Host setup

The AMI security settings need to be changed to enable the debug server to communicate over TCP/IP.

The following inbound ports need to be opened:

- TCP 3010
- TCP 22

Ports can be opened by selecting the instance and clicking its security group in the bottom panel and editing the Inbound settings. The following example configuration shows a setup which enables connections from anywhere. Arm also recommends restricting incoming addresses to specific IP addresses for additional security.

Figure 1: Example configuration for AWS security settings

3.3 Client setup

As a first step, Arm recommends that you explore the Arm Development Studio Getting Started Guide.

Download the configuration database from the path "/home/ec2-user/developmentstudio-workspace/AWS_M33x2_Bronze" to local directory.

Do this by connecting to the instance over SSH, the IP address is supplied under the Connect button, an example is shown below in Figure 2 Connect To Your Instance, the name of the .pem file and IP address will change on your usage
Figure 2 Connect To Your Instance

In your Unix shell you can scp the configuration database to your local machine, an example is given below. Note the IP address will be different every time you start an instance, use the IP address provided by the AWS console.

```
scp -r -i "arm_ds.pem" ec2-user@ec2-34-240-108-143.eu-west-1.compute.amazonaws.com:/home/ec2-user/developmentstudio-workspace/AWS_M33x2_Bronze ./
```

Use the following steps to import configuration database provided as part of the AMI into Arm DS.

1. Launch Arm DS
2. **Click File > Import...** as shown in Figure 3 Importing an existing configuration database
Figure 3 Importing an existing configuration database

2. Select **General > Existing Projects into Workspace** in the pop-up window shown in Figure 4 Importing existing Project into Workspace
3. In the **Import Projects** dialog select the path to configuration database from your local directory and select the "Copy projects into workspace" option before clicking **Finish** as shown in Figure 5 Importing an existing configuration database.
Figure 5 Importing an existing configuration database

4. Select Window -> Preferences as shown in Figure 6 Rebuilding imported configuration database
5. In the Preferences dialog choose Arm DS -> Configuration Database option and select the imported configuration database under "User Configuration Databases". Now, click on the "Rebuild database" and "OK" to complete the process as shown in Figure 7 Rebuilding imported configuration database.

![Image of Preferences dialog](image)

**Figure 6 Rebuilding imported configuration database**

3.4 Using Arm DS with DesignStart FPGA on cloud

The FPGA module on the AWS instance must be cleared and loaded with an image and payload before we connect Arm DS to the instance. Connect to the instance and run the following commands on the AWS instance to achieve this:
1. Connect to the instance via SSH, as before the name of the .pem file and IP address will change on your usage

   ssh -i "arm_ds.pem" ec2-user@ec2-34-240-108-143.eu-west-1.compute.amazonaws.com

2. The next step is to clear the FPGA and load the AFI

   #Load FPGA image: Terminal session 1
   sudo fpga-clear-local-image -S 0
   sudo fpga-load-local-image -S 0 -I agfi-04868158ad82abd7e

3. Now SSH again and setup the a Virtual UART in a different console

   #Virtual UART : Terminal session 2
   ssh -i "arm_ds.pem" ec2-user@ec2-34-240-108-143.eu-west-1.compute.amazonaws.com
   cd /home/ec2-user/vUART
   sudo ./uart 0x000 0x004 0x008 ./out.txt 1

4. Switching back to the first terminal, load the example software image Load software payload: Terminal session 1

   #Load FPGA image: Terminal session 1
   cd /home/ec2-user/preloader
   sudo ./preload_software -S 0 -p ./TestPayloads/single_file_test/Hello_World.axf

5. Start the debug server

   sudo bash
   cd /opt/arm/developmentstudio-2019.1/sw/debughw/debug_server
   export LD_LIBRARY_PATH=/opt/arm/developmentstudio-2019.1/sw/debughw/debug_server
   ./rddidap_serverd -log -rddi_dap_dll ./librddi_3rd_party_probe_aws.so -debuglog

3.5 Creating new Arm DS debug configuration

The following steps will guide you through the process of setting up a new debug configuration on a local Arm DS installation.

1. Click Run > Debug Configurations... on the Arm DS menu bar as shown in the Figure 8 Debug Configuration

![Debug Configuration](image)
2. Set the target to Arm > AWS_M33x2_Bronze > Bare Metal Debug > Cortex-M33 under the CONNECTION tab in the "Debug Configurations" dialog. Choose the "AWS Virtual Debug" option from the Target Connection drop down list. Now, set the connection to the IP address provided by AWS, see Figure 9 Public IP address location as an example:

```
server=<AWS Instance Public IP Address>;probe=none
```

![Figure 9 Public IP address location](image)

3. Click "Debug" as shown in the Figure 10 Creating a new debug configuration
Figure 10 Creating a new debug configuration

4. The debug connection with the target on AWS FPGA cloud is as shown in the Figure 11
   Connected to target on AWS FPGA cloud
Figure 11 Connected to target on AWS FPGA cloud
4 Building, running, and debugging test applications

This section of the guide shows the process of building, running, and debugging using a simple Hello World example and a more complicated trusted firmware example. The software will be built by Arm DS on a local machine and then run on an AWS instance with the local Arm DS debugger attached.

4.1 Hello World Example

4.1.1 Creating the Arm DS project

Here are the steps to create a simple "Hello World" project.

1. Create a new C project:
   If you have no projects open, click New Project in the Project Explorer view.
   Otherwise, select: File > New > Project.
2. Expand the C/C++ menu, and select C project, then click Next.
3. In the C Project dialog:
   In the Project name field, enter HelloWorld.
   Under Project type, select Executable > Hello World ANSI C Project.
   Under Toolchains, select Arm Compiler 6.
   Click Finish.
4. In the Project Explorer view, right-click the HelloWorld project and select Properties. The Properties for HelloWorld dialog box opens.

5. Add debug symbols into the image file:
   Expand C/C++ Build, and select Build Variables
   Set Configuration to Debug [Active].

6. Set the linker base RAM address, under C/C++ Build select Settings
   In the Tool Settings tab, select All Tools Settings > Target.
   From the Target CPU dropdown, select Cortex-M33.
   From the Target FPU dropdown, select No FPU.

7. Select Tool Settings > Arm Linker 6 > Image Layout.
   In the RO base address field, enter 0x80000000.
   Click OK.

8. If you are prompted to rebuild the index, click Yes.

9. In the Project Explorer view, right-click the HelloWorld project, and select Build Project.
4.1.2 Configure your debug session

A debug configuration was created in Section 3.5. The next step is to select the AWS instance and enter the correct server address, which is available from AWS console.

![Debug Configuration](image)

Figure 13 Target selection

1. Select the **Files** tab and click the **Workspace** button to find the file HelloWorld.axf
Figure 14 Program selection

2. Next step is to move to Debugger tab and select "Debug from symbol" option and click Debug.

Figure 15 Debug choice
If for some reason you fail to connect, ensure the debugger server is running on the instance as in section Using Arm DS with DesignStart FPGA on cloud. Typically, this might be caused if you stop or pause the instance.

3. Once connected, click the **green play button** to run the program and present the output in the console window.

![Program output](image)

Figure 16 Program output
4.2 Arm Trusted Firmware M (TF-M) Example

This example is based on Arm Trusted firmware M, which provides a reference implementation of secure world software for ARMv8-M. For the purpose of this example Ubuntu 18.04 is used as the operating system.

4.2.1 Dependencies

Please review the **TF-M Software requirements** before you begin to ensure you have the correct build tools installed.

At this point of time TF-M does not support ARM Compiler V6.13 which comes with Arm DS version 2019.1, so ARM Compiler V6.12, this needs to be downloaded and installed. The download is available from [developer.arm.com](http://developer.arm.com)

Once installed, this tool chain needs to be added to Arm DS as shown in Figure 17 Arm DS Tool Chain addition

![Arm DS Tool Chain addition](image)

Figure 17 Arm DS Tool Chain addition

4.2.2 Building TF-M

1. Install **Git LFS**. Copy the link to the latest version for **Linux AMD64**. Then run the following commands:
wget https://github.com/git-lfs/git-lfs/releases/download/v2.9.0/git-lfs-linux-amd64-v2.9.0.tar.gz # Replace this link with the one you copied from the webpage
tar xf git-lfs-linux-amd64-v2.8.0.tar.gz # Replace this name with the name of the file you downloaded
sudo ./install.sh

2. Clone the various git repositories; this example uses Linux for the sample, **instructions for Windows** are also available.

```bash
mkdir tfm
cd tfm
git clone https://git.trustedfirmware.org/trusted-firmware-m.git -b TF-Mv1.0-RC2
git clone https://github.com/ARMmbed/mbedtls.git -b mbedtls-2.7.9
```  
git clone https://github.com/ARMmbed/mbed-crypto.git -b mbedcrypto-1.1.0
```bash
git clone https://github.com/ARM-software/CMSIS_5.git -b 5.5.0
pushd CMSIS_5
```  
git lfs install
```bash
git lfs pull
```  
```bash
popd
```

3. It is possible to build TF-M just using the command line, detailed instructions are available on git.trustedfirmware.org under **build instructions**. The target you should choose is "SSE-200_AWS". However, in this example we are using Arm DS to build and compile the project.

4. **Launch Arm DS**

5. As a first step the project needs to have access to TF-M code, so select **File > Import**

6. On the import dialogue select "Existing Code as Makefile Project"

7. On the "New Project" dialogue create a project name then browse to the root of the TF-M repository, select the Arm Compiler 6.12 tool chain and then press "Finish". This will create a new project.
8. Right click the project and select "Build Targets" then "Create..."
   a. On the "Create Build Target" dialogue set:
   b. The target name to: gen-<config>-<build-type>-<platform>-<compiler> where:
   c. config is the name of the TF-M configuration the target builds
   d. build-type is either debug or release
e. platform is the name of the target platform (i.e sse-200_aws)

f. compiler is the name of the compiler to be used (i.e armclang) For example for the "Regression Test" build configuration a debug build targeting sse-200_aws compiled with armclang the name will be: "gen-regression-debug-sse-200_aws-clang"

g. Untick the "Same as target name" checkbox.

h. Clear the "Build target" edit box.

i. Untick the "Use builder settings" checkbox and enter the following command, then click OK

```bash
bash -c "{" cmake -E remove_directory build && cmake -E make_directory build && cd build && cmake -G'Unix Makefiles' -DCMAKE_BUILD_TYPE=Debug -DPROJ_CONFIG=<path>/trusted-firmware-m/configs/ConfigRegression.cmake -D
TARGET_PLATFORM=SSE-200_AWS -D COMPILER=ARMCLANG ../ ;}"
```

Figure 19 Build regression target

9. Repeat step 8 by right click the project and select "Build Targets" then "Create..." once complete click OK

a. Set the "Target name" to build
b. Clear the "Build target:" box

c. Set the "Build command:" box to

cmake --build ./build

Figure 20 Create Build Target

10. Under the project "trusted-firmware-m" expand the "Build Targets" and right click
    gen-regression-debug-sse-200_aws-clang target and select "Build Target"

11. Repeat step 10 this time right clicking build target and select "Build Target"

12. Example binaries will be created

   • mcuboot.bin (under tfm/trusted-firmware-m/build/bl2/ext/mcuboot/)
   • tfm_sign.bin (under tfm/trusted-firmware-m/build)

13. These binaries needed to be copied to the AWS instance and preloaded into memory, this will
    be detailed in section Loading and running the binaries on AWS
4.2.3 Loading and running the binaries on AWS

1. Use scp or another tool, copy the resulting binary file to the AWS instance. See below for an example running from the build directory, note the IP address will be different and will be available from "AWS Connect to Your Instance dialog box"

   ```
   scp -i "arm_ds.pem" tfm_sign.bin ec2-user@ec2-34-240-108-143.eu-west-1.compute.amazonaws.com:
   scp -i "arm_ds.pem" ./bl2/ext/mcuboot/mcuboot.bin ec2-user@ ec2-34-240-108-143.eu-west-1.compute.amazonaws.com:
   ```

2. SSH into the instance

   ```
   ssh -i "arm_ds.pem" ec2-user@ ec2-34-240-108-143.eu-west-1.compute.amazonaws.com
   ```

3. The FPGA module must be cleared and loaded with an image before we run our payload. To do this, run the following code on the AWS instance:

   ```
   sudo fpga-clear-local-image -S 0
   sudo fpga-load-local-image -S 0 -I agfi-04868158ad82abd7e
   ```

4. If the debug server is not already running, start it and put it in the background using the following commands.

   ```
   sudo bash
   cd /opt/arm/developmentstudio-2019.1/sw/debughw/debug_server
   export LD_LIBRARY_PATH=/opt/arm/developmentstudio-2019.1/sw/debughw/debug_server
   ./rddidap_serverd -log -rddi_dap_dll ./librddi_3rd_party_probe_aws.so -debuglog
   ```

5. To capture the output of the payload, open a virtual UART receiver in another terminal window with the following commands.

   a. Open a new shell and SSH in again

   ```
   ssh -i "arm_ds.pem" ec2-user@ ec2-34-240-108-143.eu-west-1.compute.amazonaws.com
   ```

   b. In this shell start a virtual UART

   ```
   sudo ~/vUART/uart 0x0 0x4 0x8 ~/uart_output 0
   ```

6. Switching back to the first shell, load the binary files into the FPGA with the following command. The program will begin executing immediately.

   ```
   sudo ~/preloader/preload_software -S 0 -b mcuboot.bin 0x10000000 -b tfm_sign.bin 0x10080000
   ```

   The output of the project is visible on the virtual UART and captured in file called "uart_output"

4.2.4 Debugging TF-M example

These steps take you through the creation of a new Arm DS debug configuration a shown in

Click Run > Debug Configurations... on the Arm DS menu bar, and create a new configuration for Generic Arm C/C++ Application.
1. Set the target to Arm > AWS FPGA > Bare Metal Debug > Cortex-M33 under the Connection tab.
   a. Select AWS_M33_Bronze>Bare Metal Debug>Cortex-M33
   b. Set the Target Connection to AWS Virtual Debug
   c. Then set the connection to:
      
      ```
      server=<AWS IP>;probe=None
      ```

      ![](debug_configuration.png)

      **Figure 21 Debug Configuration**

2. Switch to the Files tab and set the location of the debug symbols
3. Select **Debugger** tab and select **Debug from symbol**: main as shown in Figure 23 Debug from main and click **Debug**.
Figure 23 Debug from main

4. Now the connection is made, disassembled code, memory and registers can be viewed
Figure 24 Debugger connection
5 Troubleshooting

5.1 How do I start debugging from main?

Insert the following code at the beginning of the main function under tfm-test/[Source directory]/bl2/ext/mcuboot/bl2_main.c:

```
{
  volatile int i = 1;
  while (i) {} 
}
```

Initially, the payload will be stuck in an infinite loop. Connect the debugger and modify the value of variable `i` to 0 to resume execution.

**The debugger cannot connect to the AWS server.**

Check the following configurations:

- The AWS firewall must be configured to allow inbound connections to certain ports. Refer to Section 3 Setting up AWS and Arm DS.
- The debug server must be running on the AWS instance. Refer to Section 3 Setting up AWS and Arm DS.
- The IP address of the AWS instance changes across reboots. Check that the current IP address is used in the debug configuration.

5.2 Can't debugging both CPUs

In order to debug both CPUs in the system, you first need to bring both CPUs out of reset, you can do this by loading a software payload as below. If you load a single payload you will not able to connect to the second CPU as it will be held in reset.

```
./preload_software -S 0 -p ./TestPayloads/single_file_test/MultiCore_Bringup.elf
```

This will print the following in the vUART

```
Cortex-M33 0
Cortex-M33 1
```

Assuming the debug server is up and running, you can use select which CPU to connect to as in Figure 10 Creating a new debug configuration.
Appendix A : Terminology

Arm DS

Arm Development Studio

AWS

Amazon Web Services

FPGA

Field Programmable Gate Array

AFI

Amazon FPGA Image

AMI

Amazon Machine Image

TF-M

Trusted Firmware M