Integrator™/CP
Board Support Package for
Microsoft Windows CE .NET
Revision: r0p0

Application Developer’s Guide
Integrator/CP Board Support Package for Microsoft Windows CE .NET Application Developer’s Guide

Copyright © 2004 ARM Limited. All rights reserved.

Release Information

The table below shows the release state and change history of this document.

<table>
<thead>
<tr>
<th>Date</th>
<th>Issue</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 March 2004</td>
<td>A</td>
<td>First release for r0p0.</td>
</tr>
</tbody>
</table>

Proprietary Notice

Words and logos marked with ® or ™ are registered trademarks or trademarks of ARM Limited in the EU and other countries, except as otherwise stated below in this proprietary notice. Other brands and names mentioned herein may be the trademarks of their respective owners.

Neither the whole nor any part of the information contained in, or the product described in, this document may be adapted or reproduced in any material form except with the prior written permission of the copyright holder.

The product described in this document is subject to continuous developments and improvements. All particulars of the product and its use contained in this document are given by ARM Limited in good faith. However, all warranties implied or expressed, including but not limited to implied warranties of merchantability, or fitness for purpose, are excluded.

This document is intended only to assist the reader in the use of the product. ARM Limited shall not be liable for any loss or damage arising from the use of any information in this document, or any error or omission in such information, or any incorrect use of the product.

Confidentiality Status

This document is Non-Confidential. The right to use, copy and disclose this document may be subject to license restrictions in accordance with the terms of the agreement entered into by ARM and the party that ARM delivered this document to.

Product Status

The information in this document is final, that is for a developed product.

Web Address

http://www.arm.com
Contents

Integrator/CP Board Support Package for Microsoft Windows CE .NET Application Developer’s Guide

Preface

About this book ............................................................................................................. x
Feedback .................................................................................................................. xiii

Chapter 1 Introduction

1.1 About the Windows CE .NET Board Support Package ................................. 1-2

Chapter 2 Development Environment

2.1 Host workstation ............................................................................................. 2-2
2.2 Connecting to the Integrator/CP development board ................................. 2-3
2.3 Booting the OS .................................................................................................. 2-4
2.4 Building a sample application ....................................................................... 2-5
2.5 Using ActiveSync to download the sample application ............................. 2-8
List of Tables
Integrator/CP Board Support Package for Microsoft Windows CE .NET Application Developer’s Guide

Table 2-1 Null-modem cable interconnections for ActiveSync .................................................. 2-3
Table 2-2 ActiveSync configuration settings ............................................................................. 2-9
List of Tables
List of Figures

Integrator/CP Board Support Package for Microsoft Windows CE .NET Application Developer’s Guide

Figure 2-1  Windows CE .NET ready screen ................................................................. 2-4
Figure 2-2  HelloWorld application running on the WCE emulator ............................. 2-6
Figure 2-3  Make New Connection dialog box .............................................................. 2-8
Figure 2-4  Device Properties dialog box ................................................................... 2-8
Figure 2-5  PC Connection Properties dialog box ...................................................... 2-9
Figure 2-6  ActiveSync Get Connected dialog box ..................................................... 2-10
Figure 2-7  Replog connection dialog box on target ................................................... 2-10
Figure 2-8  ActiveSync window after connection to the target .................................... 2-11
Preface

This preface introduces the *Integrator/CP Board Support Package for Windows CE .NET Application Developer's Guide*. It contains the following sections:

- *About this book* on page x
- *Feedback* on page xiii.
About this book

This is the Application Developer's Guide (DG) for the Integrator/CP Board Support Package for Windows CE .NET. It describes the use of the system on the following core modules:

- CM920T
- CM922T-XA10
- CM926EJ-S
- CM1026EJ-S.

Product revision status

The rnpn identifier indicates the revision status of the product described in this guide, where:

- **rn**: Identifies the major revision of the product.
- **pn**: Identifies the minor revision or modification status of the product.

Intended audience

This guide is written for developers who are creating Windows CE .NET applications for the ARM Integrator/CP. This guide assumes that you are familiar with eMbedded Visual C++.

Using this manual

This manual is organized into the following chapters:

**Chapter 1 Introduction**

Read this chapter for an overview of the Integrator/CP application development system.

**Chapter 2 Development Environment**

Read this chapter for a description of how to configure and use the Windows CE .NET OS development environment.
Typographical conventions

The following typographical conventions are used in this book:

*italic*          Highlights important notes, introduces special terminology, denotes internal cross-references, and citations.

*bold*           Highlights interface elements, such as menu names. Denotes ARM processor signal names. Also used for terms in descriptive lists, where appropriate.

*monospace*       Denotes text that can be entered at the keyboard, such as commands, file and program names, and source code.

*monospace*       Denotes a permitted abbreviation for a command or option. The underlined text can be entered instead of the full command or option name.

*monospace italic* Denotes arguments to monospace text where the argument is to be replaced by a specific value.

*monospace bold*  Denotes language keywords when used outside example code.

Further reading

This section lists publications from both ARM Limited and third parties.

ARM Limited periodically provides updates and corrections to its documentation. See http://www.arm.com for current errata sheets, addenda, and the ARM Limited Frequently Asked Questions list.

ARM publications

This manual contains information that is specific to the Integrator/CP Development System. See o the following document(s) for other relevant information:

- ARM Integrator documents:
  - *ARM Integrator/CP Compact Platform User Guide* (ARM DUI 0159)
  - *ARM Integrator/CM922T-XA10 Core Module User Guide* (ARM DUI 0184)
• ARM Multi-ICE documents:
  — Multi-ICE Version 2.2 User Guide (ARM DUI 0048)
• ADS Version 1.2 AXD and armsd Debuggers Guide (ARM DUI 0066)
• Trace Debug Tools Version 1.2 User Guide (ARM DUI 0118)

Other publications

This section lists relevant documents published by third parties:
• Microsoft, Microsoft eMbedded Visual C++ 4.0, available at http://msdn.microsoft.com/visualc/
Feedback

ARM Limited welcomes feedback on both the Integrator/CP Development System, and its documentation.

Feedback on the Integrator/CP Development System

If you have any comments or suggestions about this product, contact your supplier giving:
• the product name
• a concise explanation of your comments.

Feedback on this book

If you have any comments on this manual, send email to errata@arm.com giving:
• the title
• the number
• the relevant page number(s) to which your comments apply
• a concise explanation of your comments.

ARM Limited also welcomes general suggestions for additions and improvements.
Chapter 1

Introduction

This chapter provides an overview of the Integrator/CP application development system. It contains the following section:

1.1 About the Windows CE .NET Board Support Package

This section gives a brief outline of the Windows CE .NET Board Support Package (BSP) for the Integrator/CP:

* Features
* Tools
* Software revisions.

1.1.1 Features

The Integrator/CP Application Development System for Windows CE .NET is designed for use with the following core modules:

- CM920T
- CM922T-XA10
- CM926EJ-S
- CM1026EJ-S.

This BSP enables you to take the working system and add your own applications to help make a fully functional product in a short time. It supports:

- VGA and Color LCD screen output, at 640x480 in 16-bit
- User interaction using a PS/2 mouse and PS/2 keyboard
- Audio playback and record.

1.1.2 Tools

You build and test your applications with Microsoft eMbedded Visual C++ 4.0. You then download these applications with Microsoft ActiveSync.

1.1.3 Software revisions

The software revisions for use with the BSP are:

- Windows CE .NET version 4.2.
Chapter 2
Development Environment

This chapter describes how to configure and use the Windows CE .NET development environment. It contains the following sections:

- *Host workstation* on page 2-2
- *Connecting to the Integrator/CP development board* on page 2-3
- *Booting the OS* on page 2-4
- *Building a sample application* on page 2-5
- *Using ActiveSync to download the sample application* on page 2-8.
2.1 Host workstation

The recommended host workstation is a Windows NT or Windows 2000 OS-based PC, with two free serial ports, and HyperTerminal or a similar application installed.

2.1.1 eMbedded Visual C++

You must ensure that Microsoft eMbedded Visual C++ 4.0 is properly installed on the host PC. During installation, you must select support for at least ARMv4 Interworking (ARMv4I) and the Windows CE Emulator (WCE). This ensures that the correct CPU support packages are available when you build your applications.

The WCE emulator enables you to debug your applications before downloading them to the Integrator/CP.
2.2 Connecting to the Integrator/CP development board

See the Integrator/CP Board Support Package for Windows CE .NET User Guide for instructions on how to set up the target platform.

To connect to the Integrator/CP development board:

1. Connect a null-modem or crossover cable between port B (bottom serial port) on the Integrator/CP platform and the host PC COM2.
2. Connect another serial cable between port A (top serial port) on the CP board and the host PC COM1.
3. Ensure that the null-modem cable wiring is interconnected between two nine-pin female connectors, as shown in Table 2-1, or ActiveSync cannot work.

Table 2-1 Null-modem cable interconnections for ActiveSync

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Abbreviation</th>
<th>From pin</th>
<th>To pin</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Carrier Detect</td>
<td>DCD</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>Received Data</td>
<td>RD or Rx</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>Transmitted Data</td>
<td>TD or Tx</td>
<td>3</td>
<td>2</td>
</tr>
<tr>
<td>Data Terminal Ready</td>
<td>DTR</td>
<td>4</td>
<td>1 and 6</td>
</tr>
<tr>
<td>Signal Ground</td>
<td>SG or GND</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Data Set Ready</td>
<td>DSR</td>
<td>6</td>
<td>4</td>
</tr>
<tr>
<td>Request To Send</td>
<td>RTS</td>
<td>7</td>
<td>8</td>
</tr>
<tr>
<td>Clear To Send</td>
<td>CTS</td>
<td>8</td>
<td>7</td>
</tr>
<tr>
<td>Ring Indicator</td>
<td>RING or RI</td>
<td>9</td>
<td>9</td>
</tr>
</tbody>
</table>
2.3 Booting the OS

Launch a HyperTerminal session on the host PC:

1. Configure the port settings as follows. Set:
   • bits per second to 38400
   • data bits to 8
   • parity to none
   • stop bits to 1
   • flow control to none.

2. Follow the instructions in the Integrator/CP Board Support Package for Windows CE .NET User Guide to set up the DIP switches and flash images on the platform so that the Windows CE .NET OS can boot up.

When the OS starts to run, the HyperTerminal window shows the text Windows CE Kernel for ARM and other boot sequence output.

3. Figure 2-1 shows that loading and initialization have completed. You can now download your user-developed application.

    Note

The icons displayed in the main window might vary from those shown in Figure 2-1. They depend on which OS binary is shipped.

---

Figure 2-1 Windows CE .NET ready screen
2.4 Building a sample application

This section shows you how to use eMbedded Visual C++ to produce a simple HelloWorld application. These instructions assume that you are familiar with the eMbedded Visual C++ interface.

1. Launch eMbedded Visual C++.

2. Select File → New… from the menus.

3. Select a WCE MFC AppWizard (exe) project and name it HelloWorld in the New dialog box.

4. Choose a suitable work directory location for the project and select Win32 (WCE ARMv4I) and Win32 (WCE emulator) as the CPU support. Click OK.

5. The WCE MFC AppWizard (exe) dialog now appears:
   b. Select Next > again to accept the defaults in step 2.
   c. Choose the Statically linked MFC library option in step 3.
   d. Click Finish to accept the defaults in the rest of the steps.
   e. A review of your chosen options is shown in the next dialog, select OK to create the project.


   Note
   There are several ways of achieving this. See the eMbedded Visual C++ help for more information on using its development interface.

7. Change the code in the OnPaint function so it resembles the code below:

   ```cpp
   void CChildView::OnPaint()
   {
     CPaintDC dc(this); // device context for painting
     CString s = "Hello World";
     CRect rect;
     GetClientRect(&rect);
     dc.DrawText( s, -1, &rect, DT_SINGLELINE | DT_CENTER | DT_VCENTER );
   }
   ```

8. Select Tools → Options from the menus. Alter the Download options tab so that Always download binary to the target and Always download dependencies to the target are turned OFF.
9. Compile and build your program using the **Build → Build HelloWorld.exe** menu option. This builds the WCE emulator version by default.

10. Select **Build → Start Debug → Go** from the menus. This starts the emulator and downloads the test application.

11. You are asked to find `commdlg.dll` to enable full debugging. Select **Cancel**.

    Figure 2-2 shows the WCE emulator window when the application is running.

12. In eMbedded Visual C++, select **Debug → Stop Debugging**. This leaves the WCE emulator running but you can close this as well.

13. Select **Build → Set Active Configuration...** and choose **HelloWorld - Win32 (WCE ARMV4I) Release** from the **Set Active Project Configuration** dialog list box. Click **OK**.

14. Use **Build → Build HelloWorld** to compile again but this time it is for the target device.
15. The ARMv4IRel directory in your project directory contains HelloWorld.exe. You can now download this to your target using ActiveSync. See *Using ActiveSync to download the sample application* on page 2-8 for a description of how to do this.

16. You can start the application on the target and see the same results as the WCE Emulator when it is downloaded.
2.5 Using ActiveSync to download the sample application

ActiveSync is the standard method for providing PC connectivity for Windows CE devices. It contains two parts:

- The host-side Windows application named ActiveSync. This can be downloaded from the Microsoft web site.
- The target (device) end component named rep11og. This might not be included in the OS binary for some releases. Check the release notes for details.

2.5.1 Setting up the target connection properties

Before initiating the connection, you first set up the target (device) end connection properties. You must do this every time you reset the target:

1. Open the target (device) end Control Panel. Use Start → Settings → Control Panel or navigate from My Computer.

2. Select Network and Dial-up Connections, then select Make New Connection. Figure 2-3 shows the Make New Connection dialog box that appears.

3. Select Direct Connection for the connection type and then choose Next >. Ensure that Serial Cable on COM1: is selected as the connection device.

4. Click on Configure…. The Device Properties dialog box is displayed.
5. Select the settings listed in Table 2-2.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual Dial</td>
<td>no</td>
</tr>
<tr>
<td>Use Terminal window before dialing</td>
<td>no</td>
</tr>
<tr>
<td>Use terminal window after dialing</td>
<td>no</td>
</tr>
<tr>
<td>Baud Rate</td>
<td>57600</td>
</tr>
<tr>
<td>Data Bits</td>
<td>8</td>
</tr>
<tr>
<td>Parity</td>
<td>None</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>1</td>
</tr>
<tr>
<td>Flow Control</td>
<td>None</td>
</tr>
</tbody>
</table>

6. Select OK on the Device Properties dialog box and again on the subsequent Windows CE Networking dialog box about the changes.

7. Select Finish to complete the new connection.

8. Return to the Control Panel by closing the Network Connections window.

9. Select PC Connection, then select Change… in the PC Connection Properties dialog box shown in Figure 2-5.

10. Choose My Connection from the drop-down in the Change Connection dialog box, and press OK.

11. Select OK to the connection change in the PC Connection Properties dialog box.
2.5.2 Using ActiveSync

To use ActiveSync:

1. Start the ActiveSync program on the host PC to display the Get Connected dialog box shown in Figure 2-6.

![Figure 2-6 ActiveSync Get Connected dialog box](image)

If it is not displayed, select File → Get Connected… from the ActiveSync program menu.

2. Start the Repllog.exe application on the target. This program is located in the Windows directory, or you can enter Repllog into the Start → Run… dialog box. Figure 2-7 shows the dialog box.

![Figure 2-7 Repllog connection dialog box on target](image)

3. Return to the host PC and press Next > on the Get Connected dialog. ActiveSync now searches for a target to connect to.

4. If you have performed Steps 2 and 3 within four seconds then the connection is made and, after a short time, ActiveSync indicates this on the host PC.
If the connection is not successful, the **Get Connected** dialog box displays the failure:

a. Check all of your connection settings.
b. Check that the cable is plugged in to the correct target port.
c. Return to step 2 and try again.

5. A new dialog box named **New Partnership** displays on the host PC, select **No** and then choose **Next >**.

6. Press the **Explore** button on the ActiveSync window toolbar to bring up an explorer window. This shows the contents of the target desktop and enables you to copy files to and from your target. Figure 2-8 shows the ActiveSync window.

![ActiveSync window after connection to the target](image)

**Figure 2-8 ActiveSync window after connection to the target**

7. Copy your *HelloWorld.exe* from your sample application project directory (see *Building a sample application* on page 2-5, step 15), and paste it into the Explorer window for the target.
# Index

The items in this index are listed in alphabetical order. The references given are to page numbers.

## A
- ActiveSync 1-2, 2-1, 2-8
  - cable connections 2-3
  - configuration settings 2-9
  - connecting 2-10
  - downloading applications 2-8
  - running 2-10
  - window 2-11
- Applications
  - building 2-5
  - downloading 2-8
- Audio playback 1-2

## B
- Board Support Package, see BSP
- Booting the operating system 2-4
- BSP
  - features 1-2
  - testing 1-2
  - tools 1-2

## C
- Cable connections 2-3
- Connection
  - new 2-8
  - properties 2-8, 2-9
- Connection target, setting up 2-8
- Conventions, typographical xi

## D
- Device properties 2-8
- DIP switches 2-4

## E
- eMbedded Visual C++ 2-2

## F
- Flash images 2-4

## H
- HelloWorld 2-5, 2-8
- Host workstation 2-2
- HyperTerminal 2-2, 2-4

## I
- Integrator/CP, connecting to 2-3

## K
- Keyboard type 1-2
Index

M
Mouse type 1-2

N
Null-modem pinout 2-3

O
Operating system, booting 2-4

P
Ports 2-3
  configuring 2-4
Product revision status x
Product revisions 1-2

R
Ready screen 2-4
Recording facility 1-2
Repilog connection 2-10
Revision status x

S
Sample application
  building 2-5
  downloading 2-8
Screen output 1-2
Software revisions 1-2

T
Target devices, setting up 2-8
Typographical conventions xi

W
WCE 2-2